Revit 2020 API |
Autodesk.Revit.DB.IFC Namespace |
Classes
Class | Description | |
---|---|---|
![]() | ExporterIFC |
The main class provided by Revit to allow implementation of IFC export.
|
![]() | ExporterIFCUtils |
A class that contains utilities needed to implement Revit's version of the IFC export client application.
|
![]() | HostObjectSubcomponentInfo |
A class that contains roof or floor slab information, calculated by ExporterIFCUtils.ComputeSubcomponents().
|
![]() | IFCAggregate |
A collection of IFC handles or attributes.
|
![]() | IFCAggregateIterator |
A class used to iterate individual objects in an IFCAggregate.
|
![]() | IFCAnyHandle |
A handle representing an item in an IFC file.
|
![]() | IFCConnectedWallData |
A class that contains the IFC-specific information about how an element is joined to another element.
|
![]() | IFCData |
A specialized type of abstract data block that can represent any data type.
|
![]() | IFCExtrusionCalculatorOptions |
This class contains the options used to calculate extrusions from Revit geometry.
|
![]() | IFCExtrusionCalculatorUtils |
A utility class used to calculate extrusion data from Revit geometry for IFC export.
|
![]() | IFCExtrusionCreationData |
A utility object that is used to pass information related to extrusion creation.
|
![]() | IFCExtrusionData |
Represents the geometry of an extrusion (a solid body or opening) generated
from Revit geometry.
|
![]() | IFCFamilyInstanceExtrusionExportResults |
This class represents the results of a geometric analysis of a family instance.
|
![]() | IFCFile |
Represents the IFC file which is being created during export.
|
![]() | IFCFileModelOptions |
This class contains options to create an IFC file model.
|
![]() | IFCFileReadOptions |
This class contains options to read an IFC file.
|
![]() | IFCFileWriteOptions |
This class contains options to write an IFC file.
|
![]() | IFCGeometryInfo |
A container class for Revit geometry extracted from an element.
|
![]() | IFCImportOptions |
IFC Import options.
|
![]() | IFCLegacyStairOrRamp |
The class contains the components of a legacy stair or ramp.
|
![]() | IFCLevelInfo |
Represents information about a particular level in the document.
|
![]() | IFCOpeningData |
A class that contains opening data including extrusion data, opening solids and opening element id.
|
![]() | IFCProductWrapper |
This class is used to ensure that elements and objects are associated with the current IfcProduct.
|
![]() | IFCRange |
Typically for IFC export, this represents the lower and upper elevations for split wall and column geometry.
|
![]() | IFCTransaction |
IFC transactions are context-like objects that guard any changes made to an IFC file.
|
![]() | IFCTransformSetter |
A state-based class that forces an extra transformation applied to objects being exported.
|
![]() | ImporterIFC |
The main class provided by Revit to allow implementation of IFC import.
|
![]() | ImporterIFCUtils |
A class that contains utilities needed to implement Revit's version of the IFC import client application.
|
![]() | RoofComponents |
A class that contains multiple roof slab infos of a roof.
|
Interfaces
Interface | Description | |
---|---|---|
![]() | IExporterIFC |
The interface used to implement a custom IFC exporter.
|
![]() | IIFCImporterServer |
Interface for external servers implementing IFC import.
|
Enumerations
Enumeration | Description | |
---|---|---|
![]() | IFCConnectedWallDataLocation |
An enumerated type that represents the location where an element is connected to a wall.
|
![]() | IFCDataPrimitiveType |
Used in operations to specify the primitive type of an IFCData.
|
![]() | IFCExtrusionAxes |
Represents the possible axes to try when generating an extrusion using IFCCreateExtrusionData.
|
![]() | IFCExtrusionBasis |
This enumerated type represents the possible bases for derivation of extrusion geometry.
|
![]() | IFCFileFormat |
The IFC file format.
|
![]() | IFCImportAction |
The action of the IFC import.
|
![]() | IFCImportIntent |
The intent of the IFC import.
|
![]() | IFCLogical |
A datatype can have values TRUE, FALSE or UNKNOWN.
|
![]() | IFCProjectLevelGUIDType |
The type of the GUID to be retrieved from Revit.
|