Revit 2020 API |
DockablePane Members |
DockablePane Class Constructors Methods Properties See Also |
The DockablePane type exposes the following members.
Constructors
Name | Description | |
---|---|---|
![]() | DockablePane(DockablePane) |
Constructs a new copy of the input DockablePane object.
|
![]() | DockablePane(DockablePaneId) |
Gets the pane with identifier %id%.
|
Methods
Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the DockablePane |
![]() | Equals | (Inherited from Object.) |
![]() | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.) |
![]() | GetTitle |
Returns the current title (a.k.a. window caption) of the dockable pane.
|
![]() | GetType | Gets the Type of the current instance. (Inherited from Object.) |
![]() | Hide |
If the pane is on screen, hide it. Has no effect on built-in Revit dockable panes.
|
![]() | IsShown |
Identify the pane is currently visible or in a tab.
|
![]() ![]() | PaneExists |
Returns true if %id% refers to a dockable pane window that currently exists in the Revit user interface, whether it's hidden or shown.
|
![]() ![]() | PaneIsBuiltIn |
Returns true if %id% refers to a built-in Revit dockable pane, rather than one created by an add-in.
|
![]() ![]() | PaneIsRegistered |
Returns true if %id% refers to a built-in Revit dockable pane, or an add-in pane that has been properly registered with %Autodesk.Revit.UI.UIApplication.RegisterDockablePane%.
|
![]() | Show |
If the pane is not currently visible or in a tab, display the pane in the Revit user interface at its last docked location.
|
![]() | ToString | Returns a string that represents the current object. (Inherited from Object.) |
Properties
Name | Description | |
---|---|---|
![]() | Id |
The unique identifier for this dockable pane.
|
![]() | IsValidObject |
Specifies whether the .NET object represents a valid Revit entity.
|