Revit 2022.1 API |
IExternalApplication..::..OnStartup Method |
IExternalApplication Interface See Also |
Implement this method to execute some tasks when Autodesk Revit starts.
Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 22.0.0.0 (22.1.1.0)
Syntax
C# |
---|
Result OnStartup( UIControlledApplication application ) |
Visual Basic |
---|
Function OnStartup ( _ application As UIControlledApplication _ ) As Result |
Visual C++ |
---|
Result OnStartup( UIControlledApplication^ application ) |
Parameters
- application
- Type: Autodesk.Revit.UI..::..UIControlledApplication
A handle to the application being started.