AnalyticalModel represents the Analytical Model portion of a given Structural Element.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since:
2011
Syntax
Remarks
AnalyticalModel is made up of the following information:
- Curves, representing the graphical representation of the Element with respect to analysis.
- Support Information.
- Adjustment Information, both Manual and Automatic.
- Parameter Information, including projection, hard points, approximation, and rigid links.
- Analytical Offset.
- AnalyticalModelSurface - represents analytical model for Structural Floor, Structural Foundation Slab and Structural Wall.
- AnalyticalModelStick - represents analytical model for Structural Framing Beam, Structural Framing Brace and Structural Column.
- AnalyticalModelColumn - represents analytical model for Structural Column.
Inheritance Hierarchy
System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB.Structure..::..AnalyticalModel
Autodesk.Revit.DB.Structure..::..AnalyticalModelStick
Autodesk.Revit.DB.Structure..::..AnalyticalModelSurface
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB.Structure..::..AnalyticalModel
Autodesk.Revit.DB.Structure..::..AnalyticalModelStick
Autodesk.Revit.DB.Structure..::..AnalyticalModelSurface