An element that represents a stick in the structural analytical model.
Could be one of beam, brace or column type.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since:
2015
Syntax
C# |
---|
public class AnalyticalModelStick : AnalyticalModel |
Visual Basic |
---|
Public Class AnalyticalModelStick _ Inherits AnalyticalModel |
Visual C++ |
---|
public ref class AnalyticalModelStick : public AnalyticalModel |
Inheritance Hierarchy
System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB.Structure..::..AnalyticalModel
Autodesk.Revit.DB.Structure..::..AnalyticalModelStick
Autodesk.Revit.DB.Structure..::..AnalyticalModelColumn
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB.Structure..::..AnalyticalModel
Autodesk.Revit.DB.Structure..::..AnalyticalModelStick
Autodesk.Revit.DB.Structure..::..AnalyticalModelColumn