Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 23.0.0.0 (23.1.0.0)
Syntax
C# |
---|
public class ExportLineweightTable : IEnumerable<KeyValuePair<ExportLineweightKey, ExportLineweightInfo>>, IDisposable |
Visual Basic |
---|
Public Class ExportLineweightTable _ Implements IEnumerable(Of KeyValuePair(Of ExportLineweightKey, ExportLineweightInfo)), _ IDisposable |
Visual C++ |
---|
public ref class ExportLineweightTable : IEnumerable<KeyValuePair<ExportLineweightKey^, ExportLineweightInfo^>>, IDisposable |
Remarks
This table is structured as a mapping from ExportLineweightKey to ExportLineweightInfo members. The ExportLineweightKey contains the identification information for the pattern table: the Revit line weight. The ExportLineweightInfo contains the line weight to use in the export format.
The table can be accessed via direct iteration as a collection of KeyValuePairs, or by traversal of the stored keys obtained from GetKeys(), or via specific lookup of a key constructed externally. In all cases, the ExportLineweightInfo returned will be a copy of the ExportLineweightInfo from the table. In order to make changes to the ExportLineweightInfo and use those settings during export, set the modified ExportLineweightInfo back into the table using the same key.
Inheritance Hierarchy
Autodesk.Revit.DB..::..ExportLineweightTable