A constraint that controls the length of a segment.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:
2012
Syntax
C# |
---|
public class RebarShapeConstraintSegmentLength : RebarShapeConstraint |
Visual Basic |
---|
Public Class RebarShapeConstraintSegmentLength _ Inherits RebarShapeConstraint |
Visual C++ |
---|
public ref class RebarShapeConstraintSegmentLength : public RebarShapeConstraint |
Remarks
The constraint has two references, indexed by 0 and 1, that do not have to
correspond to the start and end of the segment.
Inheritance Hierarchy
System..::..Object
Autodesk.Revit.DB.Structure..::..RebarShapeConstraint
Autodesk.Revit.DB.Structure..::..RebarShapeConstraintSegmentLength
Autodesk.Revit.DB.Structure..::..RebarShapeConstraint
Autodesk.Revit.DB.Structure..::..RebarShapeConstraintSegmentLength