Autodesk.Revit.DB.Structure Namespace
 

Classes

  ClassDescription
Public classAnalyticalElement
Base class for a structural analytical elements. AnalyticalElement represents the analytical portion of a given Structural Element.
Public classAnalyticalLink
An analytical link element that is used to create connections between other Analytical Elements.
Public classAnalyticalLinkType
An object that specifies the analysis properties for an AnalyticalLink element.
Public classAnalyticalMember
Represents a linear element in the structural analytical model.
Public classAnalyticalModelSelector
Defines a portion of an Analytical Model for an Element.
Public classAnalyticalNodeData
This class holds information related to analytical model.
Public classAnalyticalOpening
An element that represents an Opening in an Analytical Panel element.
Public classAnalyticalPanel
An element that represents a surface in the Structural Analytical Model.
Public classAnalyticalSurfaceBase
This is the base class for analytical surface elements.
Public classAnalyticalToPhysicalAssociationManager
Class which manages the associations between analytical elements and physical elements.
Public classAreaLoad
An object that represents a force applied across an area.
Public classAreaLoadType
AreaLoadType class
Public classAreaReinforcement
An object that represents an Area Reinforcement within the Autodesk Revit project.
Public classAreaReinforcementCurve
An object that specifies the type of a floor in Autodesk Revit.
Public classAreaReinforcementType
An object that specifies the type of a Structural Area Reinforcement element in Autodesk Revit.
Public classBendingDetailCustomFieldProperties
Represents the properties of a Bending Detail Custom Field.
Public classBoundaryConditions
An object that represents a force applied across an area.
Public classCodeCheckingParameterServiceData
The data needed by code checking server to perform code checking.
Public classConnectionInputPoint
An object that holds information about a connection input point
Public classConnectionInputPointInfo
An object that holds description information about a connection input point
Public classEndTreatmentType
An end treatment type object that is used to hold information about the end treatment applied to bars that are connected to a coupler.
Public classExtElemChangeBeamSectionRegistry
An object that stores IExtElemChangeBeamSection
Public classFabricArea
An object that represents an Fabric Area Distribution within the Autodesk Revit project. It is container for Fabric Sheet elements.
Public classFabricAreaType
A FabricAreaType object is used in FabricArea object generation.
Public classFabricReinSpanSymbol
Represents an instance of a Structural Fabric Reinforcement Symbol in Autodesk Revit.
Public classFabricRoundingManager
Provides access to element reinforcement roundings overrides.
Public classFabricSheet
An object that represents an Fabric Sheet Element within the Autodesk Revit project.
Public classFabricSheetType
Represents a fabric sheet type, used in the generation of fabric wires.
Public classFabricWireItem
Provides implementation for FabricWires stored in a Custom Fabric Sheet
Public classFabricWireType
A Fabric Wire Type object that is used in the generation of Fabric Wire.
Public classFamilyStructuralMaterialTypeFilter
A filter used to match families that have the given structural material type.
Public classHub
Represents a connection between two or more Autodesk Revit Elements.
Public classLineLoad
An object that represents a force/moment applied in a linear manner.
Public classLineLoadType
LineLoadType class
Public classLoadBase
The LoadBase object is the base class for all load objects within the Autodesk Revit API. Data members
Public classLoadCase
An object that represents a load usage.
Public classLoadCombination
An object that represents a load combination.
Public classLoadComponent
An object that represents a load combination component.
Public classLoadNature
An object that represents a load nature.
Public classLoadTypeBase
The base class for LoadTypes
Public classLoadUsage
An object that represents a load usage.
Public classMemberForces
An object that represents a member forces on analytical element.
Public classMemberForcesServiceData
The data needed by member forces server to perform type definition.
Public classPathReinforcement
An object that represents an Path Reinforcement within the Autodesk Revit project.
Public classPathReinforcementType
An object that specifies the type of a Structural Path Reinforcement element in Autodesk Revit.
Public classPathReinSpanSymbol
Represents a Path Reinforcement Span Symbol element in Autodesk Revit.
Public classPointLoad
An object that represents a force/moment applied to a single point. Data members
Public classPointLoadType
PointLoadType class
Public classRebar
Represents a rebar element in Autodesk Revit.
Public classRebarBarType
A Rebar type object that is used in the generation of Rebar
Public classRebarBendData
The values in this class provide a summary of information taken from the RebarBarType, RebarHookType, and RebarStyle.
Public classRebarBendingDetail
Utility class with methods needed for the bending details in view.
Public classRebarBendingDetailType
Type for rebar bending detail elements.
Public classRebarConstrainedHandle
A class representing a handle on a Rebar that can be joined to a reference, such as a host Element's surface or cover, or another Rebar's handle.
Public classRebarConstraint
A class representing a constraint on a handle of a rebar element.
Public classRebarConstraintsManager
A class used to obtain information about the constraints (RebarConstraints) acting on the shape handles (RebarConstrainedHandles) of a Rebar element, and modify the constraints.
Public classRebarContainer
An object that represents an Rebar Container Element within the Autodesk Revit project.
Public classRebarContainerItem
Provides implementation for Rebar stored in RebarContainer.
Public classRebarContainerIterator
An iterator to a Rebar Container.
Public classRebarContainerParameterManager
Provides implementation of RebarContainer parameters overrides.
Public classRebarContainerType
Represents a Rebar Container Type, used in the generation of Rebar Container.
Public classRebarCoupler
Represents a rebar coupler element in Autodesk Revit.
Public classRebarCoverType
A named value for a clear cover distance.
Public classRebarCurvesData
The class that contains the information needed to calculate and return the result of the external curve generation.
Public classRebarFreeFormAccessor
A class that is used to access the properties and capabilities of free-form Rebar.
Public classRebarHandleNameData
This class is used to contain the information about the rebar handle name defined by an external application.
Public classRebarHandlePositionData
The class that contains data for the handle position calculation.
Public classRebarHandlesData
This class is used to contain the information about the rebar handles defined by an external application.
Public classRebarHookType
A Rebar Hook type object that is used in the generation of Rebar.
Public classRebarHostData
Interface to rebar-specific data stored in each valid rebar host element.
Public classRebarInSystem
Represents a rebar element that is part of a system.
Public classRebarPropagation
An utility class containing functions that can be used to propagate rebar elements.
Public classRebarReinforcementData
class containing the id and the end of rebar on which the coupler stays
Public classRebarRoundingManager
Provides access to element reinforcement roundings overrides.
Public classRebarShape
RebarShape specifies the shape type for a Rebar instance.
Public classRebarShapeConstraint
A dimension or other constraint that takes part in a RebarShapeDefinition.
Public classRebarShapeConstraint180DegreeBendArcLength
A constraint which can be applied to a RebarShapeSegment, and causes the segment to be replaced with a 180-degree arc. The associated parameter drives the arc length.
Public classRebarShapeConstraint180DegreeBendRadius
A constraint which can be applied to a RebarShapeSegment, and causes the segment to be replaced with a 180-degree arc. The associated parameter drives the radius of the arc.
Public classRebarShapeConstraint180DegreeDefaultBend
A constraint which can be applied to a RebarShapeSegment, and causes the segment to be replaced with a 180-degree arc. The arc's radius is not specified by the shape; instead it is a "default bend radius," taken from the RebarBarType associated with the Rebar instance.
Public classRebarShapeConstraintAngleFromFixedDir
A constraint which can be applied to a RebarShapeSegment and drives the angle of the segment relative to a fixed direction in UV-space.
Public classRebarShapeConstraintArcLength
An arc-length constraint associated with an arc in a RebarShapeDefinition.
Public classRebarShapeConstraintChordLength
A constraint that can be applied to a RebarShapeDefinitionByArc and drives the straight distance between the arc endpoints.
Public classRebarShapeConstraintCircumference
A circumference constraint associated with an arc in a RebarShapeDefinition.
Public classRebarShapeConstraintDiameter
A diameter constraint associated with an arc in a RebarShapeDefinition.
Public classRebarShapeConstraintFixedSegmentDir
A constraint that can be applied to a RebarShapeSegment and fixes the direction of the segment in UV-space.
Public classRebarShapeConstraintProjectedSegmentLength
A constraint that measures the length of a segment as measured by projecting onto a direction that is not parallel to the segment.
Public classRebarShapeConstraintRadius
A radius constraint associated with an arc in a RebarShapeDefinition.
Public classRebarShapeConstraintSagittaLength
A constraint that can be applied to a RebarShapeDefinitionByArc and drives the height of the arc.
Public classRebarShapeConstraintSegmentLength
A constraint that controls the length of a segment.
Public classRebarShapeDefinition
A class to assist in defining rebar shapes. A RebarShape element needs exactly one RebarShapeDefinition.
Public classRebarShapeDefinitionByArc
Definition of a shape whose size and position can determined by a single arc.
Public classRebarShapeDefinitionBySegments
Definition of a shape in terms of one or more straight segments of rebar, with arc bends between the segments.
Public classRebarShapeDrivenAccessor
A class that is used to access the properties and capabilities of shape-driven Rebar.
Public classRebarShapeMultiplanarDefinition
A specification for a simple 3D rebar shape.
Public classRebarShapeParameters
Class containing functions that create and retrieve shared parameters for RebarShapes.
Public classRebarShapeSegment
Part of a RebarShapeDefinitionBySegments, representing one segment of a shape definition. Makes sure constraints of type RebarShapeConstraintFixedSegmentDir are uniquely set. If we try to aquire a second constraint of type RebarShapeConstraintFixedSegmentDir we delete the old one.
Public classRebarShapeVertex
A bend between segments of a rebar shape definition.
Public classRebarSystemSpanSymbol
Represents a Rebar System Span Symbol element in Autodesk Revit.
Public classRebarTrimExtendData
The class that contains the information needed to calculate and return the curves in a trimmed/extended state, and also find the constraints that trim/extend it.
Public classRebarUpdateCurvesData
Class holding the information needed to calculate the rebar curves.
Public classReinforcementAbbreviationTag
This class is used to access the Area or Path Reinforcement abbreviation tag data. It stores abbreviation tag value and abbreviation type.
Public classReinforcementData
Abstract class for various reinforcement data
Public classReinforcementRoundingManager
A base class providing access to reinforcement rounding overrides for structural elements.
Public classReinforcementSettings
Provides access to project-wide reinforcement settings.
Public classReleaseConditions
An object that represents a Release Conditions on analytical element.
Public classStructuralConnectionApprovalType
A type element that represents a connection approval type.
Public classStructuralConnectionHandler
An object of Structural Connection Handler.
Public classStructuralConnectionHandlerType
A StructuralConnectionHandlerType is used in StructuralConnectionHandler element generation.
Public classStructuralConnectionSettings
Provides access to project-wide structural connections settings.
Public classStructuralConnectionType
A type element that represents a connection symbol applied to structural members.
Public classStructuralFramingUtils
A collection of Structural Framing Utilities.
Public classStructuralInstanceUsageFilter
A filter used to find elements that are structural family instances (typically columns, beams or braces) of the given structural usage.
Public classStructuralMaterialTypeFilter
A filter used to match family instances that have the given structural material type.
Public classStructuralSectionsServiceData
The data needed by section type server to perform type definition.
Public classStructuralSettings
Provides access to project-wide structural settings.
Public classStructuralWallUsageFilter
A filter used to match walls that have the given structural wall usage.
Public classTruss
Represents all kinds of Trusses.
Public classTrussMemberInfo
Provides access to the information of a truss member in Autodesk Revit.
Public classTrussType
Represents a specific type of truss.

Interfaces

  InterfaceDescription
Public interfaceICodeCheckingParameterServer
Interface for the code checking parameter server to implement.
Public interfaceIExtElemChangeBeamSection
Interface Change Beam section functionality to be implemented in add-ins
Public interfaceIMemberForcesServer
Interface for the Member Forces server to implement.
Public interfaceIRebarUpdateServer
Represents an interface that should be overridden to allow the generation and update of free form rebar geometry.
Public interfaceIStructuralSectionsServer
Interface for the section type parameter server to implement.

Enumerations

  EnumerationDescription
Public enumerationAlignedFreeFormSetOrientationOptions
Orientation options for Aligned Free Form Rebar set.
Public enumerationAnalyticalAlignmentMethod Obsolete.
Specifies how analytical model is being aligned in space
Public enumerationAnalyticalCurveSelector
Specifies which portion of an Analytical Curve is of interest.
Public enumerationAnalyticalCurveType Obsolete.
Identifies what type of Analytical Model curves should be extracted.
Public enumerationAnalyticalDirection Obsolete.
Specifies a direction for manipulating analytical model.
Public enumerationAnalyticalElementSelector
Specifies a portion of an Analytical Element or the whole element.
Public enumerationAnalyticalFixityState
Specifies the fixity setting of individual degrees of freedom in analytical release conditions.
Public enumerationAnalyticalLoopType
Specifies kind of analytical model loop.
Public enumerationAnalyticalNodeConnectionStatus
Indicates the Connections Status for an Analytical Node.
Public enumerationAnalyticalProjectionType Obsolete.
Presets for given Analytical Projection. Combined with AnalyticalDirection, this abstracts Analytical Projections for all Structural Elements
Public enumerationAnalyticalRigidLinksOption
Specifies how Rigid Links will be made for the Analytical Model.
Public enumerationAnalyticalStructuralRole
Indicates the structural role for the analytical elements.
Public enumerationAnalyticalSupportPriority
Defines how "highly" another Element is giving support for one Element.
Public enumerationAnalyticalSupportType
Indicates what kind of support another Element provides -- Point, Surface, or Curve.
Public enumerationAnalyzeAs
Analyze As has various functions within the Analytical Model, and is Element-dependent. "Not for Analysis" usually means that there will not be an Analytical Model generated. The others indicate how the Analytical Model behavior will treat the Element in question. For instance "Hanger" columns have different support expectations than "Gravity" columns.
Public enumerationAreaReinforcementLayerType
Describes the layers of an Area Reinforcement
Public enumerationBendingDetailAngularDimensionsDisplayOptions
Describes the angular dimensions display options.
Public enumerationBendingDetailAngularDimensionsMeasurementOptions
Describes the angular dimension measurement options.
Public enumerationBendingDetailBendDiameterDimensionType
Describes the dimension type for bend diameter.
Public enumerationBendingDetailCustomFieldMultipleValuesIndicatorOptions
Describes how the parameters with multiple values will be represented.
Public enumerationBendingDetailDimensionTextPosition
Describes how the text will be positioned with respect to dimension line.
Public enumerationBendingDetailDisplayParametersOptions
Describes how the parameters will be represented.
Public enumerationBendingDetailFor3DShapesOptions
Describes how the Bending Detail will be represented for 3D shapes.
Public enumerationBendingDetailLevelOfDetail
Describes the level of detail in which the Bending Detail will be represented.
Public enumerationBendingDetailSegmentLengthsDisplayOptions
Describes if the segment lengths are represented using dimensions or just as text.
Public enumerationBendingDetailSegmentsRepresentation
Describes how the Bending Detail will represent the bar segments.
Public enumerationBendingDetailTypeMultipleValuesIndicatorOptions
Describes how the parameters with multiple values will be represented.
Public enumerationBentFabricBendDirection
Direction in which FabricSheet is bent.
Public enumerationBentFabricStraightWiresLocation
Bent Fabric straight wires location. The side on wich straight wires will be loacted is determined by the start and end point of the first bent profile segment that specifies the direction of the curve loop on plane.
Public enumerationBoundaryConditionsOrientTo
Specifies boundary condition orientation.
Public enumerationBoundaryConditionsType
This enum declares type of BoundaryConditions.
Public enumerationBracePlanRepresentation
The possible representations for braces in plan views.
Public enumerationDistributionType
The type of the distribution
Public enumerationFabricHostReference
Controls if Single Fabric Sheet should be cut by the Host Cover.
Public enumerationFabricLapSplicePosition
Fabric lap splice position in the fabric distribution
Public enumerationFabricLocation
Fabric location in the host
Public enumerationFabricSheetAlignment
Fabric Sheet alignment in the fabric distribution
Public enumerationFabricSheetLayoutPattern
The pattern for how the wires in Fabric Sheet are laid out.
Public enumerationFabricTagComponentReference
How FabricSheet tag text will be aligned to the FabricSheet symbol.
Public enumerationLoadCaseCategory
Specifies load case category.
Public enumerationLoadCombinationState
Specifies load combination state.
Public enumerationLoadCombinationType
Specifies load combination type.
Public enumerationLoadOrientTo
Specifies load orientation.
Public enumerationLoadType
This enum declares types of Loads.
Public enumerationMultiplanarOption
Input argument type for Rebar.GetCenterlineCurves method. Controls whether all curves of a multi-planar Rebar element are returned by GetCenterlineCurves, or only the curves in the primary plane.
Public enumerationRebarConstraintTargetHostFaceType
A type to help identify the individual face on a host element to which a Rebar handle is constrained.
Public enumerationRebarConstraintType
The various types of constraints that can be applied to a RebarConstrainedHandle.
Public enumerationRebarCouplerError
Error states for the Rebar Coupler
Public enumerationRebarDeformationType
Bar deformation type
Public enumerationRebarFreeFormValidationResult
Errors for the Free Form Rebar
Public enumerationRebarGeometryType
Rebar geometry type
Public enumerationRebarHandleType
The various types of handles on a Rebar instance that can be joined to References
Public enumerationRebarHookOrientation
Orientation of a rebar hook relative to the path of the Rebar Shape.
Public enumerationRebarHostCategory
Rebar host category
Public enumerationRebarLayoutRule
The rule for how the rebars in rebar set are laid out
Public enumerationRebarPresentationMode
Bar presentation mode
Public enumerationRebarShapeArcReferenceType
A Rebar Shape Definition constraint that is measured to a bend must take the bar diameter into account by specifying whether it measures to the exterior, centerline, or interior of the bend.
Public enumerationRebarShapeBendAngle
A bend in a rebar shape has an angular range specified by one of these values. The angles refer to the angle swept out by one segment as it is bent relative to another. That is, an "Obtuse" bend results in two segments that meet at an angle that is less than 90 degrees when measured internally. Put another way, to create an equilateral triangle, you would need two "Obtuse" bends.
Public enumerationRebarShapeDefinitionByArcType
A RebarShapeDefinitionByArc takes one of three forms.
Public enumerationRebarShapeSegmentEndReferenceType
A choice of two reference points for one end of a constraint driving the length of a RebarShapeSegment.
Public enumerationRebarShapeVertexTurn
Specify whether a bend at a RebarShapeVertex represents a left or right turn.
Public enumerationRebarStyle
Describes the usage style of a RebarShape. The style affects the bend radius and the set of allowable hooks. It also affects Rebar instance auto-constraining behavior.
Public enumerationRebarWorkInstructions
Describes how a Free Form Rebar will be fabricated.
Public enumerationReinforcementAbbreviationObjectType
Defines the type of desired reinforcement object for abbreviation tags.
Public enumerationReinforcementAbbreviationTagType
Defines all types of abbreviation tags for Area and Path Reinforcement objects.
Public enumerationReinforcementBarOrientation
Describes the bar orientation at Path Reinforcement.
Public enumerationReinforcementRoundingSource
An enumerated type listing the possible sources for reinforcement rounding overrides.
Public enumerationReleaseType
The release type.
Public enumerationStickElementExtension Obsolete.
Presets for given Analytical Extension.
Public enumerationStickElementProjectionY Obsolete.
Presets for given Analytical Projection.
Public enumerationStickElementProjectionZ Obsolete.
Presets for given Analytical Projection.
Public enumerationStirrupTieAttachmentType
An enumerated tye that represents how the Stirrup/Tie rebar is attached to the cover reference.
Public enumerationStructuralConnectionApplyTo
An enumerated type that represents the type of structural locations to which a connection annotation may be applied.
Public enumerationStructuralConnectionCodeCheckingStatus
An enumerated type listing all code checking status of the structural connection element.
Public enumerationStructuralInstanceUsage
Represents the structural usage of a family instance.
Public enumerationStructuralMaterialType
Represents the structural material type. This enum value is returned by Autodesk::Revit::DB::FamilyInstance::StructuralMaterialType.
Public enumerationStructuralType
Represents the structural type of a family instance.
Public enumerationStructuralWallUsage
Represents the structural usage of a wall.
Public enumerationSurfaceElementExtension
Presets for given Analytical Extension.
Public enumerationSurfaceElementProjectionZ
Presets for given Analytical Projection Z.
Public enumerationTargetRebarConstraintType
A type used to identify the particular part of a Stirrup style rebar to which a Standard style rebar's handle is constrained.
Public enumerationTranslationRotationValue
Specifies the type of condition applied to the translation or rotation parameter.
Public enumerationTrussChordLocation
This enumerated type represents the options for the Truss Chord Location.
Public enumerationTrussCurveType
Types of curves created in truss families.
Public enumerationTrussMemberType
Indicates the "kind" of a truss member.
Public enumerationWireDistributionDirection
Defines the direction of the distribution of wires in a Fabric Sheet.
Public enumerationYJustification
The justification of the framing element in Y.
Public enumerationYZJustificationOption
The option for whether a framing element has independent or uniform justification on its ends.
Public enumerationZJustification
The justification of the framing element in Z.