Revit 2024 API |
RebarShapeSegmentEndReferenceType Enumeration |
See Also |
A choice of two reference points for one end of a constraint driving the length of
a RebarShapeSegment.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:
2012
Since:
2012
Syntax
C# |
---|
public enum RebarShapeSegmentEndReferenceType |
Visual Basic |
---|
Public Enumeration RebarShapeSegmentEndReferenceType |
Visual C++ |
---|
public enum class RebarShapeSegmentEndReferenceType |
Members
Member name | Description |
---|---|
Straight | Refers to the end of the straight part of the segment: the point where the bend begins. |
Exterior | Refers to the farthest point on the arc of the bend. Assuming the bend is 90 degrees or more, an Exterior constraint will be longer than a Straight constraint by an amount equal to the bend radius. |
Remarks
The RebarShapeSegmentEndReferenceType of a constraint is meaningful only
when the bend is
right or
obtuse.
If the bend is
acute,
the reference type is ignored.