A class that is used to access the properties and capabilities of free-form Rebar.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:
2018
Syntax
C# |
---|
public class RebarFreeFormAccessor : IDisposable |
Visual Basic |
---|
Public Class RebarFreeFormAccessor _ Implements IDisposable |
Visual C++ |
---|
public ref class RebarFreeFormAccessor : IDisposable |
Remarks
Obtain an instance of this class from GetFreeFormAccessor()()()().
The accessor includes a reference to the Rebar element.
If the referenced Rebar element is deleted, using the methods form this class will throw exception.
Inheritance Hierarchy
System..::..Object
Autodesk.Revit.DB.Structure..::..RebarFreeFormAccessor
Autodesk.Revit.DB.Structure..::..RebarFreeFormAccessor