AnalyticalSurfaceBase Class
This is the base class for analytical surface elements.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2023

Syntax

C#
public class AnalyticalSurfaceBase : AnalyticalElement
Visual Basic
Public Class AnalyticalSurfaceBase _
	Inherits AnalyticalElement
Visual C++
public ref class AnalyticalSurfaceBase : public AnalyticalElement

Inheritance Hierarchy

System..::..Object
  Autodesk.Revit.DB..::..Element
    Autodesk.Revit.DB.Structure..::..AnalyticalElement
      Autodesk.Revit.DB.Structure..::..AnalyticalSurfaceBase
        Autodesk.Revit.DB.Structure..::..AnalyticalOpening
        Autodesk.Revit.DB.Structure..::..AnalyticalPanel

See Also