Revit 2024 API |
RebarShapeDefinitionByArcType Enumeration |
See Also |
A RebarShapeDefinitionByArc takes one of three forms.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Syntax
C# |
---|
public enum RebarShapeDefinitionByArcType |
Visual Basic |
---|
Public Enumeration RebarShapeDefinitionByArcType |
Visual C++ |
---|
public enum class RebarShapeDefinitionByArcType |
Members
Member name | Description |
---|---|
Arc | An arc, subtending an angle less than 360 degrees. |
LappedCircle | A full circle, subtending an angle more than 360 degrees and less than 720 degrees. The behavior in Revit is the same as Arc, but an extra complete circle is included in the rebar. |
Spiral | A helical bar. The extent of the helix is determined by the Rebar properties Height and Pitch. |