A class that is used to access the properties and capabilities of shape-driven Rebar.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:
2018
Syntax
C# |
---|
public class RebarShapeDrivenAccessor : IDisposable |
Visual Basic |
---|
Public Class RebarShapeDrivenAccessor _ Implements IDisposable |
Visual C++ |
---|
public ref class RebarShapeDrivenAccessor : IDisposable |
Remarks
Obtain an instance of this class from GetShapeDrivenAccessor()()()().
The accessor includes a reference to the Rebar element.
If the referenced Rebar element is deleted, using the methods form this class will throw exception.
Inheritance Hierarchy
System..::..Object
Autodesk.Revit.DB.Structure..::..RebarShapeDrivenAccessor
Autodesk.Revit.DB.Structure..::..RebarShapeDrivenAccessor