A class to assist in defining rebar shapes.
A RebarShape element needs exactly one RebarShapeDefinition.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:
2009
Syntax
C# |
---|
public class RebarShapeDefinition : IDisposable |
Visual Basic |
---|
Public Class RebarShapeDefinition _ Implements IDisposable |
Visual C++ |
---|
public ref class RebarShapeDefinition : IDisposable |
Remarks
A RebarShapeDefinition stores a set of Rebar Shape parameters. Each parameter
may be associated with:
- One or more RebarShapeConstraints; or
- A formula; or
- Neither of the above.
Inheritance Hierarchy
System..::..Object
Autodesk.Revit.DB.Structure..::..RebarShapeDefinition
Autodesk.Revit.DB.Structure..::..RebarShapeDefinitionByArc
Autodesk.Revit.DB.Structure..::..RebarShapeDefinitionBySegments
Autodesk.Revit.DB.Structure..::..RebarShapeDefinition
Autodesk.Revit.DB.Structure..::..RebarShapeDefinitionByArc
Autodesk.Revit.DB.Structure..::..RebarShapeDefinitionBySegments