A bend between segments of a rebar shape definition.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:
2012
Syntax
C# |
---|
public class RebarShapeVertex : IDisposable |
Visual Basic |
---|
Public Class RebarShapeVertex _ Implements IDisposable |
Visual C++ |
---|
public ref class RebarShapeVertex : IDisposable |
Remarks
A RebarShapeVertex is part of a RebarShapeDefinitionBySegments object. There is one vertex between each pair of adjacent segments, plus one at each end of the overall shape. The end vertices currently are ignored by the shape definition, even if they have constraints.
A bend may have the default radius of the bar type referenced by the Rebar element, or it may have a radius defined by a parameter.
Inheritance Hierarchy
System..::..Object
Autodesk.Revit.DB.Structure..::..RebarShapeVertex
Autodesk.Revit.DB.Structure..::..RebarShapeVertex