Represents a TopographySurface element.
Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Syntax
Remarks
TopographySurface and related classes have been replaced as of Revit 2024 with Toposolid and related classes.
It is recommended that all newly created elements and modifications operate from the new Toposolid class. The TopographySurface element remains in the API for backwards compatibility and upgrade.
A TopographySurface element in the Revit API represents:
- An actual topography surface which can have an arbitrary boundary and collection of points.
- A SiteSubRegion element bounded by a sketch.
- A topography surface created automatically by the introduction of a BuildingPad element.
Inheritance Hierarchy
System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB.Architecture..::..TopographySurface
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB.Architecture..::..TopographySurface