Revit 2024 API |
BalusterInfo..::..TopReferenceName Property |
BalusterInfo Class See Also |
Represents the name of the reference for the top of this baluster or post.
Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:
2019
Syntax
C# |
---|
public string TopReferenceName { get; set; } |
Visual Basic |
---|
Public Property TopReferenceName As String Get Set |
Visual C++ |
---|
public: property String^ TopReferenceName { String^ get (); void set (String^ value); } |
Remarks
Two pre-defined reference names can be obtained using [!:Autodesk::Revit::DB::Architecture::BalusterInfo::getReferenceNameForHost()] or
[!:Autodesk::Revit::DB::Architecture::BalusterInfo::getReferenceNameForTopRail()].
The rest of valid reference names that are allowed to be used in the setter for TopReferenceName
are the actual names of non-continuous rails [!:Autodesk::Revit::DB::Architecture::NonContinuousRailInfo::Name]
in [!:Autodesk::Revit::DB::Architecture::NonContinuousRailStructure]
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The name doesn't refer to a valid reference. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was null |