The event arguments used by the DialogBoxShowing event when a Windows message box is about to be displayed in Revit.
Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:
2010
Syntax
C# |
---|
public class MessageBoxShowingEventArgs : DialogBoxShowingEventArgs |
Visual Basic |
---|
Public Class MessageBoxShowingEventArgs _ Inherits DialogBoxShowingEventArgs |
Visual C++ |
---|
public ref class MessageBoxShowingEventArgs : public DialogBoxShowingEventArgs |
Remarks
When the application receives this object, a simple message box is about to be displayed in Revit that
requires user interaction. The OverrideResult function can be used to cause the dialog
to be dismissed and return a desired result code.
Inheritance Hierarchy
System..::..Object
System..::..EventArgs
Autodesk.Revit.DB.Events..::..RevitAPIEventArgs
Autodesk.Revit.DB.Events..::..RevitAPIPreEventArgs
Autodesk.Revit.UI.Events..::..DialogBoxShowingEventArgs
Autodesk.Revit.UI.Events..::..MessageBoxShowingEventArgs
System..::..EventArgs
Autodesk.Revit.DB.Events..::..RevitAPIEventArgs
Autodesk.Revit.DB.Events..::..RevitAPIPreEventArgs
Autodesk.Revit.UI.Events..::..DialogBoxShowingEventArgs
Autodesk.Revit.UI.Events..::..MessageBoxShowingEventArgs