Revit 2024 API |
AlignmentStationLabel..::..CreateSet Method |
AlignmentStationLabel Class See Also |
Creates a collection of AlignmentStationLabel objects along with their underlying SpotDimension elements.
Namespace: Autodesk.Revit.DB.Infrastructure
Assembly: Autodesk.CivilAlignments.DBApplication (in Autodesk.CivilAlignments.DBApplication.dll) Version: 24.0.0.0 (24.0.0.0)
Since:
2021.1
Syntax
C# |
---|
public static ICollection<AlignmentStationLabel> CreateSet( Alignment alignment, View view, AlignmentStationLabelSetOptions options ) |
Visual Basic |
---|
Public Shared Function CreateSet ( _ alignment As Alignment, _ view As View, _ options As AlignmentStationLabelSetOptions _ ) As ICollection(Of AlignmentStationLabel) |
Visual C++ |
---|
public: static ICollection<AlignmentStationLabel^>^ CreateSet( Alignment^ alignment, View^ view, AlignmentStationLabelSetOptions^ options ) |
Parameters
- alignment
- Type: Autodesk.Revit.DB.Infrastructure..::..Alignment
The alignment on which the alignment station label is placed.
- view
- Type: Autodesk.Revit.DB..::..View
The view for which the alignment station label is created.
- options
- Type: Autodesk.Revit.DB.Infrastructure..::..AlignmentStationLabelSetOptions
The alignment station options of the label set to be created.