An object that represents a gutter within the Autodesk Revit project.
Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Syntax
C# |
---|
public class Gutter : HostedSweep |
Visual Basic |
---|
Public Class Gutter _ Inherits HostedSweep |
Visual C++ |
---|
public ref class Gutter : public HostedSweep |
Remarks
This object derived from the Element base object and such supports all the
methods of that object such as the ability to retrieve the parameters of that object.
Inheritance Hierarchy
System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..HostObject
Autodesk.Revit.DB..::..HostedSweep
Autodesk.Revit.DB.Architecture..::..Gutter
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..HostObject
Autodesk.Revit.DB..::..HostedSweep
Autodesk.Revit.DB.Architecture..::..Gutter