The base class of the RibbonItem event arguments which have UIApplication property.
Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 24.0.0.0 (24.0.0.0)
Syntax
C# |
---|
public class RibbonItemEventArgs : EventArgs |
Visual Basic |
---|
Public Class RibbonItemEventArgs _ Inherits EventArgs |
Visual C++ |
---|
public ref class RibbonItemEventArgs : public EventArgs |
Inheritance Hierarchy
System..::..Object
System..::..EventArgs
Autodesk.Revit.UI.Events..::..RibbonItemEventArgs
Autodesk.Revit.UI.Events..::..ComboBoxCurrentChangedEventArgs
Autodesk.Revit.UI.Events..::..ComboBoxDropDownClosedEventArgs
Autodesk.Revit.UI.Events..::..ComboBoxDropDownOpenedEventArgs
Autodesk.Revit.UI.Events..::..TextBoxEnterPressedEventArgs
System..::..EventArgs
Autodesk.Revit.UI.Events..::..RibbonItemEventArgs
Autodesk.Revit.UI.Events..::..ComboBoxCurrentChangedEventArgs
Autodesk.Revit.UI.Events..::..ComboBoxDropDownClosedEventArgs
Autodesk.Revit.UI.Events..::..ComboBoxDropDownOpenedEventArgs
Autodesk.Revit.UI.Events..::..TextBoxEnterPressedEventArgs