This method provides a direct entry point to get access to an object from the ReCap SDK (ReCapWrapper.RCProject) from Revit. This object represents the point cloud from the RC file path stored in PointCloudType. The ReCap assembly AdskRcManaged.dll will need to be included into code using this method.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022
Syntax
C# |
---|
public RCProject GetReCapProject() |
Visual Basic |
---|
Public Function GetReCapProject As RCProject |
Visual C++ |
---|
public:
RCProject^ GetReCapProject() |
Remarks
Examples
CopyC#
private Autodesk.RealityComputing.Managed.RCProject GetRCProject(Document doc)
{
PointCloudType type = PointCloudType.Create(doc, "rcs", "c:\\32_cafeteria.rcs");
Autodesk.RealityComputing.Managed.RCProject proj = type.GetReCapProject();
UInt64 numOfPoints = proj.GetNumberOfPoints();
return type.GetReCapProject();
}
CopyVB.NET
Private Function GetRCProject(ByVal doc As Document) As Autodesk.RealityComputing.Managed.RCProject
Dim type As PointCloudType = PointCloudType.Create(doc, "rcs", "c:\32_cafeteria.rcs")
Dim proj As Autodesk.RealityComputing.Managed.RCProject = type.GetReCapProject()
Dim numOfPoints As ULong = proj.GetNumberOfPoints()
Return type.GetReCapProject()
End Function
Exceptions
See Also