GetCommonCoverType Method
If all exposed faces of the host have the same associated CoverType, return that CoverType; otherwise, return nullNothingnullptra null reference (Nothing in Visual Basic).

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2012

Syntax

C#
public RebarCoverType GetCommonCoverType()
Visual Basic
Public Function GetCommonCoverType As RebarCoverType
Visual C++
public:
RebarCoverType^ GetCommonCoverType()

Return Value

The common CoverType for all exposed faces, or nullNothingnullptra null reference (Nothing in Visual Basic) if there are multiple CoverTypes.

See Also