Revit 2025.3 API
Curve |
Transforms this curve loop and all of its component curves by the supplied transformation.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public void Transform( Transform transform )
Public Sub Transform ( transform As Transform )
public: void Transform( Transform^ transform )
member Transform : transform : Transform -> unit
Parameters
- transform Transform
- The transformation.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |
ArgumentOutOfRangeException | transform is not conformal. -or- transform has a scale that is negative or zero. |

The modified CurveLoop is guaranteed to be valid with all consituent curves contiguous (assuming
that the curves were contiguous in the input curve loop).
See Also