Revit 2025.3 API
Argument |
The exception that is thrown when is passed to a method that does not accept it as a valid argument.

SystemObject
SystemException
Autodesk.Revit.ExceptionsApplicationException
Autodesk.Revit.ExceptionsArgumentException
Autodesk.Revit.ExceptionsArgumentNullException
SystemException
Autodesk.Revit.ExceptionsApplicationException
Autodesk.Revit.ExceptionsArgumentException
Autodesk.Revit.ExceptionsArgumentNullException
Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
[SerializableAttribute] public class ArgumentNullException : ArgumentException
<SerializableAttribute> Public Class ArgumentNullException Inherits ArgumentException
[SerializableAttribute] public ref class ArgumentNullException : public ArgumentException
[<SerializableAttribute>] type ArgumentNullException = class inherit ArgumentException end
The ArgumentNullException type exposes the following members.

Name | Description | |
---|---|---|

Name | Description | |
---|---|---|
![]() | GetObjectData | Retrieves data needed to serialize the target object. (Overrides ArgumentExceptionGetObjectData(SerializationInfo, StreamingContext)) |
See Also