PointNode Class

PointNode Class

An output node that represents a 3D point.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBRenderNode
    Autodesk.Revit.DBModelCurveNode
      Autodesk.Revit.DBPointNode

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class PointNode : ModelCurveNode
Public Class PointNode
	Inherits ModelCurveNode
public ref class PointNode : public ModelCurveNode
type PointNode = 
    class
        inherit ModelCurveNode
    end

The PointNode type exposes the following members.

Properties
 NameDescription
Top
Methods
 NameDescription
Public methodGetPoint Returns the point object corresponding to the node.
Top
Remarks
See also: [!:Autodesk::Revit::DB::IModelExportContext::OnPoint].
See Also