PointNode Class

PointNode Class

An output node that represents a 3D point.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBRenderNode
    Autodesk.Revit.DBModelCurveNode
      Autodesk.Revit.DBPointNode

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class PointNode : ModelCurveNode
Public Class PointNode
	Inherits ModelCurveNode
public ref class PointNode : public ModelCurveNode
type PointNode = 
    class
        inherit ModelCurveNode
    end

The PointNode type exposes the following members.

Properties
 NameDescription
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from RenderNode)
Public propertyLineProperties Access to the line (pen) properties of the curve being drawn
(Inherited from ModelCurveNode)
Public propertyNodeName A readable name of the output node.
(Inherited from RenderNode)
Top
Methods
 NameDescription
Public methodDispose
(Inherited from RenderNode)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetPoint Returns the point object corresponding to the node.
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks
See also: [!:Autodesk::Revit::DB::IModelExportContext::OnPoint].
See Also