RenderNode Class

RenderNode Class

This is the base class of all render nodes in a model-exporting process.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBRenderNode
    More

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class RenderNode : IDisposable
Public Class RenderNode
	Implements IDisposable
public ref class RenderNode : IDisposable
type RenderNode = 
    class
        interface IDisposable
    end

The RenderNode type exposes the following members.

Properties
 NameDescription
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertyNodeName A readable name of the output node.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the RenderNode
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks
A node can be both geometric (such as an element, light, etc.) or non-geometric (e.g. material). Some types of nodes are container modes, which include other render nodes.
See Also
Inheritance Hierarchy