FaceNode Class

FaceNode Class

An output node that represents a Face.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBRenderNode
    Autodesk.Revit.DBFaceNode

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class FaceNode : RenderNode
Public Class FaceNode
	Inherits RenderNode
public ref class FaceNode : public RenderNode
type FaceNode = 
    class
        inherit RenderNode
    end

The FaceNode type exposes the following members.

Properties
 NameDescription
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from RenderNode)
Public propertyNodeName A readable name of the output node.
(Inherited from RenderNode)
Top
Methods
 NameDescription
Public methodDispose
(Inherited from RenderNode)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetFace Returns the Face object corresponding to the node.
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks
See also: [!:Autodesk::Revit::DB::IExportContext::OnFaceBegin].
See Also