FaceNode Class

FaceNode Class

An output node that represents a Face.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBRenderNode
    Autodesk.Revit.DBFaceNode

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class FaceNode : RenderNode
Public Class FaceNode
	Inherits RenderNode
public ref class FaceNode : public RenderNode
type FaceNode = 
    class
        inherit RenderNode
    end

The FaceNode type exposes the following members.

Properties
 NameDescription
Top
Methods
 NameDescription
Public methodGetFace Returns the Face object corresponding to the node.
Top
Remarks
See also: [!:Autodesk::Revit::DB::IExportContext::OnFaceBegin].
See Also