ViewNode Class

ViewNode Class

A render node that represents a view.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBRenderNode
    Autodesk.Revit.DBViewNode

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class ViewNode : RenderNode
Public Class ViewNode
	Inherits RenderNode
public ref class ViewNode : public RenderNode
type ViewNode = 
    class
        inherit RenderNode
    end

The ViewNode type exposes the following members.

Properties
 NameDescription
Public propertyLevelOfDetail The level of detail the view is going to be rendered at.
Public propertyViewId The Id of the view element.
Top
Methods
 NameDescription
Public methodGetCameraInfo Information about the observation point (the camera) of the view.
Top
Remarks
See also: [!:Autodesk::Revit::DB::IExportContext::OnViewBegin].
See Also