ViewNode Class

ViewNode Class

A render node that represents a view.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBRenderNode
    Autodesk.Revit.DBViewNode

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class ViewNode : RenderNode
Public Class ViewNode
	Inherits RenderNode
public ref class ViewNode : public RenderNode
type ViewNode = 
    class
        inherit RenderNode
    end

The ViewNode type exposes the following members.

Properties
 NameDescription
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from RenderNode)
Public propertyLevelOfDetail The level of detail the view is going to be rendered at.
Public propertyNodeName A readable name of the output node.
(Inherited from RenderNode)
Public propertyViewId The Id of the view element.
Top
Methods
 NameDescription
Public methodDispose
(Inherited from RenderNode)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetCameraInfo Information about the observation point (the camera) of the view.
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks
See also: [!:Autodesk::Revit::DB::IExportContext::OnViewBegin].
See Also