FaceDetailNode Class

FaceDetailNode Class

A base class of output nodes that represent face edges and face silhouettes.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBRenderNode
    Autodesk.Revit.DBFaceDetailNode
      Autodesk.Revit.DBFaceEdgeNode
      Autodesk.Revit.DBFaceSilhouetteNode

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class FaceDetailNode : RenderNode
Public Class FaceDetailNode
	Inherits RenderNode
public ref class FaceDetailNode : public RenderNode
type FaceDetailNode = 
    class
        inherit RenderNode
    end

The FaceDetailNode type exposes the following members.

Properties
 NameDescription
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from RenderNode)
Public propertyLineProperties Access to the line (pen) properties of the curve being drawn.
Public propertyNodeName A readable name of the output node.
(Inherited from RenderNode)
Top
Methods
 NameDescription
Public methodDispose
(Inherited from RenderNode)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetInstanceTransform Returns instance transform of the object being drawn.
Public methodGetLinkTransform Returns link transform of the object being drawn.
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also