Revit 2025.3 API
Face |
An output node that represents a Face edge.

SystemObject
Autodesk.Revit.DBRenderNode
Autodesk.Revit.DBFaceDetailNode
Autodesk.Revit.DBFaceSilhouetteNode
Autodesk.Revit.DBRenderNode
Autodesk.Revit.DBFaceDetailNode
Autodesk.Revit.DBFaceSilhouetteNode
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
The FaceSilhouetteNode type exposes the following members.

Name | Description | |
---|---|---|
![]() | IsValidObject |
Specifies whether the .NET object represents a valid Revit entity.
(Inherited from RenderNode) |
![]() | LineProperties |
Access to the line (pen) properties of the curve being drawn.
(Inherited from FaceDetailNode) |
![]() | NodeName |
A readable name of the output node.
(Inherited from RenderNode) |

Name | Description | |
---|---|---|
![]() | Dispose | (Inherited from RenderNode) |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object) |
![]() | GetFace | Returns the Face object corresponding to the node. |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object) |
![]() | GetInstanceTransform |
Returns instance transform of the object being drawn.
(Inherited from FaceDetailNode) |
![]() | GetLinkTransform |
Returns link transform of the object being drawn.
(Inherited from FaceDetailNode) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object) |

See also: [!:Autodesk::Revit::DB::IExportContext2D::OnFaceSilhouette2D].
See Also