Viewport.GetBoxOutline Method

ViewportGetBoxOutline Method

Returns the outline of the viewport on the sheet, excluding the viewport label.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public Outline GetBoxOutline()
Public Function GetBoxOutline As Outline
public:
Outline^ GetBoxOutline()
member GetBoxOutline : unit -> Outline 

Return Value

Outline
The outline of the viewport on the sheet.
Exceptions
ExceptionCondition
InvalidOperationException The viewport is not on a sheet.
See Also