Revit 2025.3 API
Viewport Class |
An element that establishes the placement of a view on a sheet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
The Viewport type exposes the following members.

Name | Description | |
---|---|---|
![]() | AssemblyInstanceId |
The id of the assembly instance to which the element belongs.
(Inherited from Element) |
![]() | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element) |
![]() | Category | Retrieves a Category object that represents the category or sub category in which the
element resides. (Inherited from Element) |
![]() | CreatedPhaseId |
Id of a Phase at which the Element was created.
(Inherited from Element) |
![]() | DemolishedPhaseId |
Id of a Phase at which the Element was demolished.
(Inherited from Element) |
![]() | DesignOption | Returns the design option to which the element belongs. (Inherited from Element) |
![]() | Document | Returns the Document in which the Element resides. (Inherited from Element) |
![]() | Geometry | Retrieves the geometric representation of the element. (Inherited from Element) |
![]() | GroupId |
The id of the group to which an element belongs.
(Inherited from Element) |
![]() | Id |
A unique identifier for an Element in an Autodesk Revit project.
(Inherited from Element) |
![]() | IsModifiable |
Identifies if the element is modifiable.
(Inherited from Element) |
![]() | IsTransient |
Indicates whether an element is transient or permanent.
(Inherited from Element) |
![]() | IsValidObject |
Specifies whether the .NET object represents a valid Revit entity.
(Inherited from Element) |
![]() | LabelLineLength | The length of the viewport label line in sheet space, measured in feet. |
![]() | LabelOffset | The offset is a two-dimensional vector from left bottom corner of the viewport with Rotation set to None to the left end of the viewport label line. The Z coordinate is ignored. |
![]() | LevelId |
The id of the level associated with the element.
(Inherited from Element) |
![]() | Location | This property is used to find the physical location of an element within a project. (Inherited from Element) |
![]() | Name | A human readable name for the Element. (Inherited from Element) |
![]() | OwnerViewId |
The id of the view that owns the element.
(Inherited from Element) |
![]() | ParameterBuiltInParameter | Retrieves a parameter from the element given a parameter id. (Inherited from Element) |
![]() | ParameterDefinition | Retrieves a parameter from the element based on its definition. (Inherited from Element) |
![]() | ParameterGuid | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element) |
![]() | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element) |
![]() | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element) |
![]() | Pinned |
Identifies if the element has been pinned to prevent changes.
(Inherited from Element) |
![]() | Rotation | The rotation of the viewport on the sheet. |
![]() | SheetId | The element id of the ViewSheet on which the viewport appears, or InvalidElementId if this viewport does not associate a view with placement onto a sheet. |
![]() | UniqueId |
A stable unique identifier for an element within the document.
(Inherited from Element) |
![]() | VersionGuid |
Get the element version Guid.
(Inherited from Element) |
![]() | ViewId | The element id of the associated View. |
![]() | ViewportPositioning | Specifies the method the viewport will be positioned on the sheet when swapped to another view. Default is set to ViewportPositioning::ViewportCenter. |
![]() | ViewSpecific |
Identifies if the element is owned by a view.
(Inherited from Element) |
![]() | WorksetId |
Get Id of the Workset which owns the element.
(Inherited from Element) |

Name | Description | |
---|---|---|
![]() | ArePhasesModifiable |
Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element.
(Inherited from Element) |
![]() ![]() | CanAddViewToSheet | Verifies that the view can be added to the ViewSheet. |
![]() | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element) |
![]() | CanBeLocked |
Identifies if the element can be locked.
(Inherited from Element) |
![]() | CanDeleteSubelement |
Checks if given subelement can be removed from the element.
(Inherited from Element) |
![]() | CanHaveTypeAssigned |
Identifies if the element can have a type assigned.
(Inherited from Element) |
![]() | ChangeTypeId(ElementId) |
Changes the type of the element.
(Inherited from Element) |
![]() ![]() | Create | Creates a new Viewport at a given location on a sheet. |
![]() | DeleteEntity |
Deletes the existing entity created by %schema% in the element
(Inherited from Element) |
![]() | DeleteSubelement |
Removes a subelement from the element.
(Inherited from Element) |
![]() | DeleteSubelements | (Inherited from Element) |
![]() | Dispose | (Inherited from Element) |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object) |
![]() | EvaluateAllParameterValues |
Evaluates all the parameters' values of the element.
(Inherited from Element) |
![]() | EvaluateParameterValues | (Inherited from Element) |
![]() | GetBoxCenter | Returns the center of the outline of the viewport on the sheet, excluding the viewport label. |
![]() | GetBoxOutline | Returns the outline of the viewport on the sheet, excluding the viewport label. |
![]() | GetDependentElements |
Get all elements that, from a logical point of view, are the children of this Element.
(Inherited from Element) |
![]() | GetEntity |
Returns the existing entity corresponding to the Schema if it has been saved in the
Element, or an invalid entity otherwise.
(Inherited from Element) |
![]() | GetEntitySchemaGuids |
Returns the Schema guids of any Entities stored in this element.
(Inherited from Element) |
![]() | GetExternalFileReference |
Gets information pertaining to the external file referenced
by the element.
(Inherited from Element) |
![]() | GetExternalResourceReference |
Gets the ExternalResourceReference associated with a specified external resource type.
(Inherited from Element) |
![]() | GetExternalResourceReferenceExpanded |
Gets the collection of ExternalResourceReference associated with a specified external resource type.
(Inherited from Element) |
![]() | GetExternalResourceReferences |
Gets the map of the external resource references referenced
by the element.
(Inherited from Element) |
![]() | GetExternalResourceReferencesExpanded |
Gets the expanded map of the external resource references referenced
by the element.
(Inherited from Element) |
![]() | GetGeneratingElementIds |
Returns the ids of the element(s) that generated the input geometry object.
(Inherited from Element) |
![]() | GetGeometryObjectFromReference |
Retrieve one geometric primitive contained in the element given a reference.
(Inherited from Element) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object) |
![]() | GetLabelOutline | Gets the outline viewport's label on the sheet. |
![]() | GetMaterialArea |
Gets the area of the material with the given id.
(Inherited from Element) |
![]() | GetMaterialIds |
Gets the element ids of all materials present in the element.
(Inherited from Element) |
![]() | GetMaterialVolume |
Gets the volume of the material with the given id.
(Inherited from Element) |
![]() | GetMonitoredLinkElementIds |
Provides the link instance IDs when the element is monitoring.
(Inherited from Element) |
![]() | GetMonitoredLocalElementIds |
Provides the local element IDs when the element is monitoring.
(Inherited from Element) |
![]() | GetOrderedParameters |
Gets the parameters associated to the element in order.
(Inherited from Element) |
![]() | GetParameter | Retrieves a parameter from the element given identifier. (Inherited from Element) |
![]() | GetParameterFormatOptions |
Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists.
(Inherited from Element) |
![]() | GetParameters | Retrieves the parameters from the element via the given name. (Inherited from Element) |
![]() | GetPhaseStatus |
Gets the status of a given element in the input phase
(Inherited from Element) |
![]() | GetProjectionToSheetTransform | Returns the transform from the view's projection space to the sheet space. |
![]() | GetSubelements |
Returns the collection of element subelements.
(Inherited from Element) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object) |
![]() | GetTypeId |
Returns the identifier of this element's type.
(Inherited from Element) |
![]() | GetValidTypes |
Obtains a set of types that are valid for this element.
(Inherited from Element) |
![]() | HasPhases |
Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId.
(Inherited from Element) |
![]() | HasViewportTransforms | Indicates if the viewport has transforms. |
![]() | IsCreatedPhaseOrderValid |
Returns true if createdPhaseId and demolishedPhaseId are in order.
(Inherited from Element) |
![]() | IsDemolishedPhaseOrderValid |
Returns true if createdPhaseId and demolishedPhaseId are in order.
(Inherited from Element) |
![]() | IsExternalFileReference |
Determines whether this Element represents an external
file.
(Inherited from Element) |
![]() | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element) |
![]() | IsMonitoringLinkElement |
Indicate whether an element is monitoring any elements in any linked models.
(Inherited from Element) |
![]() | IsMonitoringLocalElement |
Indicate whether an element is monitoring other local elements.
(Inherited from Element) |
![]() | IsPhaseCreatedValid |
Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element.
(Inherited from Element) |
![]() | IsPhaseDemolishedValid |
Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element.
(Inherited from Element) |
![]() | IsValidType(ElementId) |
Checks if given type is valid for this element.
(Inherited from Element) |
![]() | IsViewIdValidForViewport | Verifies that the Viewport can change it's view id to the input %viewId%. |
![]() | LookupParameter | Attempts to find a parameter on the element which has the given name. (Inherited from Element) |
![]() | RefersToExternalResourceReference |
Determines whether this Element uses external resources associated with
a specified external resource type.
(Inherited from Element) |
![]() | RefersToExternalResourceReferences |
Determines whether this Element uses external resources.
(Inherited from Element) |
![]() | SetBoxCenter | Moves this viewport so that the center of the box outline (excluding the viewport label) is at a given point. |
![]() | SetEntity |
Stores the entity in the element. If an Entity described by the same Schema already
exists, it is overwritten.
(Inherited from Element) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object) |

Viewports are used in Revit for purposes other than placement of
views on sheets. Thus iteration of viewport elements in the model may
locate viewports which are not assigned to sheets; you can use the
SheetId property to filter these out.
See Also