Revit 2025.3 API
Viewport Class |
An element that establishes the placement of a view on a sheet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
The Viewport type exposes the following members.

Name | Description | |
---|---|---|
![]() | LabelLineLength | The length of the viewport label line in sheet space, measured in feet. |
![]() | LabelOffset | The offset is a two-dimensional vector from left bottom corner of the viewport with Rotation set to None to the left end of the viewport label line. The Z coordinate is ignored. |
![]() | Rotation | The rotation of the viewport on the sheet. |
![]() | SheetId | The element id of the ViewSheet on which the viewport appears, or InvalidElementId if this viewport does not associate a view with placement onto a sheet. |
![]() | ViewId | The element id of the associated View. |
![]() | ViewportPositioning | Specifies the method the viewport will be positioned on the sheet when swapped to another view. Default is set to ViewportPositioning::ViewportCenter. |

Name | Description | |
---|---|---|
![]() ![]() | CanAddViewToSheet | Verifies that the view can be added to the ViewSheet. |
![]() ![]() | Create | Creates a new Viewport at a given location on a sheet. |
![]() | GetBoxCenter | Returns the center of the outline of the viewport on the sheet, excluding the viewport label. |
![]() | GetBoxOutline | Returns the outline of the viewport on the sheet, excluding the viewport label. |
![]() | GetLabelOutline | Gets the outline viewport's label on the sheet. |
![]() | GetProjectionToSheetTransform | Returns the transform from the view's projection space to the sheet space. |
![]() | HasViewportTransforms | Indicates if the viewport has transforms. |
![]() | IsExternalFileReference |
Determines whether this Element represents an external
![]() | IsViewIdValidForViewport | Verifies that the Viewport can change it's view id to the input %viewId%. |
![]() | SetBoxCenter | Moves this viewport so that the center of the box outline (excluding the viewport label) is at a given point. |

Viewports are used in Revit for purposes other than placement of
views on sheets. Thus iteration of viewport elements in the model may
locate viewports which are not assigned to sheets; you can use the
SheetId property to filter these out.
See Also