Revit 2025.3 API
ViewportViewport |
Specifies the method the viewport will be positioned on the sheet when swapped to another view. Default is set to ViewportPositioning::ViewportCenter.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public ViewportPositioning ViewportPositioning { get; set; }
Public Property ViewportPositioning As ViewportPositioning Get Set
public: property ViewportPositioning ViewportPositioning { ViewportPositioning get (); void set (ViewportPositioning value); }
member ViewportPositioning : ViewportPositioning with get, set
Property Value
ViewportPositioning
Exception | Condition |
---|---|
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration |
See Also