Element.SetEntity Method

ElementSetEntity Method

Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public void SetEntity(
	Entity entity
)
Public Sub SetEntity ( 
	entity As Entity
)
public:
void SetEntity(
	Entity^ entity
)
member SetEntity : 
        entity : Entity -> unit 

Parameters

entity  Entity
The Entity to be stored.
Exceptions
ExceptionCondition
ArgumentException Writing of Entities of this Schema is not allowed to the current add-in.
ArgumentNullException A non-optional argument was null
See Also