SpatialElementGeometryCalculator.IsRoomOrSpace Method

SpatialElementGeometryCalculatorIsRoomOrSpace Method

This indicates whether the input spatial element is a room or a space.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static bool IsRoomOrSpace(
	SpatialElement spatialElement
)
Public Shared Function IsRoomOrSpace ( 
	spatialElement As SpatialElement
) As Boolean
public:
static bool IsRoomOrSpace(
	SpatialElement^ spatialElement
)
static member IsRoomOrSpace : 
        spatialElement : SpatialElement -> bool 

Parameters

spatialElement  SpatialElement
The spatial element to be checked if it is a room or a space or not.

Return Value

Boolean
True if the input spatial element is a room or a space, false otherwise.
Exceptions
ExceptionCondition
ArgumentNullException A non-optional argument was null
See Also