Revit 2025.3 API
Export |
Gets a copy of the ExportLineweightInfo corresponding to the given ExportLineweightKey.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public ExportLineweightInfo GetExportLineweightInfo( ExportLineweightKey exportLineweightKey )
Public Function GetExportLineweightInfo ( exportLineweightKey As ExportLineweightKey ) As ExportLineweightInfo
public: ExportLineweightInfo^ GetExportLineweightInfo( ExportLineweightKey^ exportLineweightKey )
member GetExportLineweightInfo : exportLineweightKey : ExportLineweightKey -> ExportLineweightInfo
Parameters
- exportLineweightKey ExportLineweightKey
- The export line weight Key.
Return Value
ExportLineweightInfoReturns the line weight info for this key.

Exception | Condition |
---|---|
ArgumentException | An entry with the given key is not present in the table. |
ArgumentNullException | A non-optional argument was null |
See Also