Revit 2025.3 API
Curve |
Creates a new curve loop as a transformed copy of the input curve loop.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static CurveLoop CreateViaTransform( CurveLoop curveLoop, Transform transform )
Public Shared Function CreateViaTransform ( curveLoop As CurveLoop, transform As Transform ) As CurveLoop
public: static CurveLoop^ CreateViaTransform( CurveLoop^ curveLoop, Transform^ transform )
static member CreateViaTransform : curveLoop : CurveLoop * transform : Transform -> CurveLoop
Parameters
Return Value
CurveLoopThe new curve loop.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |
ArgumentOutOfRangeException | transform is not conformal. -or- transform has a scale that is negative or zero. |

The newly created CurveLoop is guaranteed to be valid with all consituent curves contiguous (assuming
that the curves were contiguous in the input curve loop).
See Also