Revit 2025.3 API
ViewIs |
Checks whether the category can have graphic overrides in this view.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public bool IsCategoryOverridable( ElementId categoryId )
Public Function IsCategoryOverridable ( categoryId As ElementId ) As Boolean
public: bool IsCategoryOverridable( ElementId^ categoryId )
member IsCategoryOverridable : categoryId : ElementId -> bool
Parameters
- categoryId ElementId
- ElementId of the category.
Return Value
BooleanTrue if category can be overridden, false otherwise.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |

Categories can be allowed to be overridden in some view types and prohibited from being overridden in others.
E.g., categories cannot be overridden in ProjectBrowser
See Also