Revit 2025.3 API
Arguments |
The exception that is thrown when each individual argument is OK, but a joint constraint is violated.

SystemObject
SystemException
Autodesk.Revit.ExceptionsApplicationException
Autodesk.Revit.ExceptionsArgumentException
Autodesk.Revit.ExceptionsArgumentsInconsistentException
SystemException
Autodesk.Revit.ExceptionsApplicationException
Autodesk.Revit.ExceptionsArgumentException
Autodesk.Revit.ExceptionsArgumentsInconsistentException
Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
[SerializableAttribute] public class ArgumentsInconsistentException : ArgumentException
<SerializableAttribute> Public Class ArgumentsInconsistentException Inherits ArgumentException
[SerializableAttribute] public ref class ArgumentsInconsistentException : public ArgumentException
[<SerializableAttribute>] type ArgumentsInconsistentException = class inherit ArgumentException end
The ArgumentsInconsistentException type exposes the following members.

Name | Description | |
---|---|---|
![]() | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception) |
![]() | FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException) |
![]() | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception) |
![]() | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception) |
![]() | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception) |
![]() | Message | Gets the error message and the parameter name, or only the error message if no parameter name is set. (Inherited from ArgumentException) |
![]() | ParamName | Gets the name of the parameter that causes this exception. (Inherited from ArgumentException) |
![]() | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception) |
![]() | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception) |
![]() | TargetSite | Gets the method that throws the current exception. (Inherited from Exception) |

Name | Description | |
---|---|---|
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object) |
![]() | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object) |
![]() | GetObjectData | Retrieves data needed to serialize the target object. (Overrides ArgumentExceptionGetObjectData(SerializationInfo, StreamingContext)) |
![]() | GetType | Gets the runtime type of the current instance. (Inherited from Exception) |
![]() | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception) |
See Also