FailureHandlingOptions.SetFailuresPreprocessor Method

FailureHandlingOptionsSetFailuresPreprocessor Method

Sets the callback to be invoked in the beginning of failure processing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public FailureHandlingOptions SetFailuresPreprocessor(
	IFailuresPreprocessor preprocessor
)
Public Function SetFailuresPreprocessor ( 
	preprocessor As IFailuresPreprocessor
) As FailureHandlingOptions
public:
FailureHandlingOptions^ SetFailuresPreprocessor(
	IFailuresPreprocessor^ preprocessor
)
member SetFailuresPreprocessor : 
        preprocessor : IFailuresPreprocessor -> FailureHandlingOptions 

Parameters

preprocessor  IFailuresPreprocessor
The callback to be invoked in the beginning of failure processing.

Return Value

FailureHandlingOptions
This FailureHandlingOptions object.
Exceptions
ExceptionCondition
ArgumentNullException A non-optional argument was null
See Also