Revit 2025.3 API
ViewRemove |
Removes a filter from the view.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public void RemoveFilter( ElementId filterElementId )
Public Sub RemoveFilter ( filterElementId As ElementId )
public: void RemoveFilter( ElementId^ filterElementId )
member RemoveFilter : filterElementId : ElementId -> unit
Parameters
- filterElementId ElementId
- ElementId of the filter.

Exception | Condition |
---|---|
ArgumentException | Filter is not applied to the view. -or- ElementId is not associated with a FilterElement. |
ArgumentNullException | A non-optional argument was null |
InvalidOperationException | The element "this View" does not belong to a project document. -or- The view type does not support Visibility/Graphics Overriddes. |
See Also