Revit 2025.3 API
Optional |
Note: This API is now obsolete.
Checks whether PDF import is available in the installed Revit.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
[ObsoleteAttribute("This method is deprecated in Revit 2024 because it will always return true. It will be removed in a future version of Revit")] public static bool IsPDFImportAvailable()
<ObsoleteAttribute("This method is deprecated in Revit 2024 because it will always return true. It will be removed in a future version of Revit")> Public Shared Function IsPDFImportAvailable As Boolean
public: [ObsoleteAttribute(L"This method is deprecated in Revit 2024 because it will always return true. It will be removed in a future version of Revit")] static bool IsPDFImportAvailable()
[<ObsoleteAttribute("This method is deprecated in Revit 2024 because it will always return true. It will be removed in a future version of Revit")>] static member IsPDFImportAvailable : unit -> bool
Return Value
BooleanTrue if a PDF import is available in the installed Revit.

PDF Import requires the presence of certain modules that are optional and may not be part of the installed Revit.
See Also