Revit 2025.3 API
Optional |
A collection of utilities that can be used to determine if a particular set of functionality is installed and available.

SystemObject
Autodesk.Revit.DBOptionalFunctionalityUtils
Autodesk.Revit.DBOptionalFunctionalityUtils
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
The OptionalFunctionalityUtils type exposes the following members.

Name | Description | |
---|---|---|
![]() ![]() | Is3DMImportLinkAvailable | Checks whether the 3DM Import/Link functionality is available in the installed Revit. |
![]() ![]() | IsAXMImportLinkAvailable | Checks whether the AXM Import/Link functionality is available in the installed Revit. |
![]() ![]() | IsDGNExportAvailable | Checks whether the DGN Export functionality is available in the installed Revit. |
![]() ![]() | IsDGNImportLinkAvailable | Checks whether the DGN Import/Link functionality is available in the installed Revit. |
![]() ![]() | IsDWFExportAvailable | Checks whether the DWF/DWFx Export functionality is available in the installed Revit. |
![]() ![]() | IsDWGExportAvailable | Checks whether the DWG Export functionality is available in the installed Revit. |
![]() ![]() | IsDWGImportLinkAvailable | Checks whether the DWG Import/Link functionality is available in the installed Revit. |
![]() ![]() | IsDXFExportAvailable | Checks whether the DXF Export functionality is available in the installed Revit. |
![]() ![]() | IsFBXExportAvailable | Checks whether the FBX Export functionality is available in the installed Revit. |
![]() ![]() | IsGraphicsAvailable | Checks whether the graphics functionality is available to support display, print, and export functionality. |
![]() ![]() | IsIFCAvailable | Checks whether IFC functionality is available in the installed Revit. |
![]() ![]() | IsNavisworksExporterAvailable | Checks whether a Navisworks Exporter is available in the installed Revit. |
![]() ![]() | IsOBJImportLinkAvailable | Checks whether the OBJ Import/Link functionality is available in the installed Revit. |
![]() ![]() | IsPDFImportAvailable | Obsolete. Checks whether PDF import is available in the installed Revit. |
![]() ![]() | IsSATImportLinkAvailable | Checks whether the SAT Import/Link functionality is available in the installed Revit. |
![]() ![]() | IsShapeImporterAvailable | Checks whether the ShapeImporter functionality is available in the installed Revit. |
![]() ![]() | IsSKPImportLinkAvailable | Checks whether the SKP Import/Link functionality is available in the installed Revit. |
![]() ![]() | IsSTEPImportLinkAvailable | Checks whether the STEP Import/Link functionality is available in the installed Revit. |
![]() ![]() | IsSTLImportLinkAvailable | Checks whether the STL Import/Link functionality is available in the installed Revit. |
See Also