OptionalFunctionalityUtils.IsNavisworksExporterAvailable Method

OptionalFunctionalityUtilsIsNavisworksExporterAvailable Method

Checks whether a Navisworks Exporter is available in the installed Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static bool IsNavisworksExporterAvailable()
Public Shared Function IsNavisworksExporterAvailable As Boolean
public:
static bool IsNavisworksExporterAvailable()
static member IsNavisworksExporterAvailable : unit -> bool 

Return Value

Boolean
True if a Navisworks Exporter is available in the installed Revit.
Remarks
A Navisworks exporter is registered via an external add-in. If no add-in has registered an exporter, this will not be a part of the session.
See Also