OptionalFunctionalityUtils.IsDWFExportAvailable Method

OptionalFunctionalityUtilsIsDWFExportAvailable Method

Checks whether the DWF/DWFx Export functionality is available in the installed Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static bool IsDWFExportAvailable()
Public Shared Function IsDWFExportAvailable As Boolean
public:
static bool IsDWFExportAvailable()
static member IsDWFExportAvailable : unit -> bool 

Return Value

Boolean
True if the DWF/DWFx Export functionality is available in the installed Revit.
Remarks
DWF/DWFx Export requires presence of certain modules that are optional and may not be part of the installed Revit.
See Also