LayoutRuleClearSpacing Class

LayoutRuleClearSpacing Class

This class indicate the layout rule of a Beam System is Clear-Spacing.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBAPIObject
    Autodesk.Revit.DBLayoutRule
      Autodesk.Revit.DBLayoutRuleClearSpacing

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class LayoutRuleClearSpacing : LayoutRule
Public Class LayoutRuleClearSpacing
	Inherits LayoutRule
public ref class LayoutRuleClearSpacing : public LayoutRule
type LayoutRuleClearSpacing = 
    class
        inherit LayoutRule
    end

The LayoutRuleClearSpacing type exposes the following members.

Constructors
 NameDescription
Public methodLayoutRuleClearSpacingConstructor of LayoutRuleFixedDistance. Create LayoutRuleFixedDistance with the values passed in.
Top
Properties
 NameDescription
Public propertyJustifyTypeGet or set the type of justification.
Public propertySpacingGet or set the spacing of the beam system.
Top
Methods
 NameDescription
Top
Remarks
To use this type of LayoutRule, the distance between the beams and the justify-type must be set.
See Also