LayoutRule Class

LayoutRule Class

The LayoutRule object is a base object for all type of layout rules for Beam System within the Autodesk Revit API.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public abstract class LayoutRule : APIObject
Public MustInherit Class LayoutRule
	Inherits APIObject
public ref class LayoutRule abstract : public APIObject
[<AbstractClassAttribute>]
type LayoutRule = 
    class
        inherit APIObject
    end

The LayoutRule type exposes the following members.

Properties
 NameDescription
Public propertyIsReadOnlyIdentifies if the object is read-only or modifiable.
(Inherited from APIObject)
Top
Methods
 NameDescription
Public methodDisposeCauses the object to release immediately any resources it may be utilizing.
(Inherited from APIObject)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks
This class just used as the base class of those concrete LayoutRule classes.
See Also