LayoutRule Class

LayoutRule Class

The LayoutRule object is a base object for all type of layout rules for Beam System within the Autodesk Revit API.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public abstract class LayoutRule : APIObject
Public MustInherit Class LayoutRule
	Inherits APIObject
public ref class LayoutRule abstract : public APIObject
[<AbstractClassAttribute>]
type LayoutRule = 
    class
        inherit APIObject
    end

The LayoutRule type exposes the following members.

Properties
 NameDescription
Top
Methods
 NameDescription
Top
Remarks
This class just used as the base class of those concrete LayoutRule classes.
See Also