LayoutRuleFixedNumber Class

LayoutRuleFixedNumber Class

This class indicate the layout rule of a Beam System is Fixed-Number.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBAPIObject
    Autodesk.Revit.DBLayoutRule
      Autodesk.Revit.DBLayoutRuleFixedNumber

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class LayoutRuleFixedNumber : LayoutRule
Public Class LayoutRuleFixedNumber
	Inherits LayoutRule
public ref class LayoutRuleFixedNumber : public LayoutRule
type LayoutRuleFixedNumber = 
    class
        inherit LayoutRule
    end

The LayoutRuleFixedNumber type exposes the following members.

Constructors
 NameDescription
Public methodLayoutRuleFixedNumberConstructor of LayoutRuleFixedNumber.
Top
Properties
 NameDescription
Public propertyIsReadOnlyIdentifies if the object is read-only or modifiable.
(Inherited from APIObject)
Public propertyNumberOfLinesGet or set the number of the beams in a beam system.
Top
Methods
 NameDescription
Public methodDisposeCauses the object to release immediately any resources it may be utilizing.
(Inherited from APIObject)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks
To use this type of LayoutRule, only the number of the beams must be set.
See Also