LayoutRuleMaximumSpacing Class

LayoutRuleMaximumSpacing Class

This class indicate the layout rule of a Beam System is Max-Spacing.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBAPIObject
    Autodesk.Revit.DBLayoutRule
      Autodesk.Revit.DBLayoutRuleMaximumSpacing

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class LayoutRuleMaximumSpacing : LayoutRule
Public Class LayoutRuleMaximumSpacing
	Inherits LayoutRule
public ref class LayoutRuleMaximumSpacing : public LayoutRule
type LayoutRuleMaximumSpacing = 
    class
        inherit LayoutRule
    end

The LayoutRuleMaximumSpacing type exposes the following members.

Constructors
 NameDescription
Public methodLayoutRuleMaximumSpacingConstructor of LayoutRuleMaximumSpacing.
Top
Properties
 NameDescription
Public propertySpacingGet or set the spacing of the beam system.
Top
Methods
 NameDescription
Top
Remarks
To use this type of LayoutRule, only the maximum spacing must be set and it must be in (0, 30000).
See Also