LayoutRuleMaximumSpacing Class

LayoutRuleMaximumSpacing Class

This class indicate the layout rule of a Beam System is Max-Spacing.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBAPIObject
    Autodesk.Revit.DBLayoutRule
      Autodesk.Revit.DBLayoutRuleMaximumSpacing

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class LayoutRuleMaximumSpacing : LayoutRule
Public Class LayoutRuleMaximumSpacing
	Inherits LayoutRule
public ref class LayoutRuleMaximumSpacing : public LayoutRule
type LayoutRuleMaximumSpacing = 
    class
        inherit LayoutRule
    end

The LayoutRuleMaximumSpacing type exposes the following members.

Constructors
 NameDescription
Public methodLayoutRuleMaximumSpacingConstructor of LayoutRuleMaximumSpacing.
Top
Properties
 NameDescription
Public propertyIsReadOnlyIdentifies if the object is read-only or modifiable.
(Inherited from APIObject)
Public propertySpacingGet or set the spacing of the beam system.
Top
Methods
 NameDescription
Public methodDisposeCauses the object to release immediately any resources it may be utilizing.
(Inherited from APIObject)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks
To use this type of LayoutRule, only the maximum spacing must be set and it must be in (0, 30000).
See Also